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1 Introduction

Sigmira is a Software Defined Radio (SDR) application program that runs on Windows.  
Sigmira offers wide band spectrograph and waterfall displays.  It also demodulates various "ham" 
radio, commercial, and military signals. 

It operates with the following signal sources:.
 RFSpace SDR-IQ and SDR-14
 RemoteSDR
 SDRplay
 Sound Card (WaveIn)
 Wav file
 RTL-SDR
 Any other via Virtual Audio Cables or VB cables

Its features include: 
 "Waterfall" and spectrograph displays of up to 2 MHz width.
 Demodulation of HFDL, PSK31, FSK, SITOR-B, CW, NFM and Flex pager signals.
 Demodulation of NATO STANAG 4285.
 Demodulation of the "Japanese Navy Slot Machine" to QPSK symbols.
 Point and click signal selection/tuning.
 Signal database with automated tuning and logging.
 Playback of saved .wav files.
 Phase plane display.
 16 bit sampling.  Typical sampling rate: 48 ksps.
 Signal strength meter.
 Adjustable squelch.
 Clock display with UTC and local time.

The distribution package includes examples of HFDL, PSK31, RTTY, SITOR-B, CW, NFM, 
JSM, Flex pager, and STANAG 4285 signals in .wav files.

http://www.saharlow.com/technology/sigmira

Sigmira is Copyright 2021 by Steven A. Harlow.

2 Program Installation

2.1 Windows Version
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If  you already have your signal source hardware installed and working then the necessary drivers 
are already in place.

Sigmira is distributed in the executable self-installer 'sigtools_1r17_installer.exe'.  To install 
Sigmira simply run the installer.

2.2 Receiver

The nicer features of Sigmira are available when it is used with the SDR-IQ, SDR-14, RTL-SDR, 
SDRplay, etc.. But it is not necessary to own receiver hardware to make use of Sigmira.

If you own an SDR device connect it to your PC via USB cable.  If Windows asks for a driver for 
the device tell it to find the drivers in the <sigtools install root>/drivers directory.  (The drivers 
are from Future Technology Devices International, Ltd. [FTDI] and are also available from their 
web site. http://www.ftdichip.com/Drivers/VCP.htm )

Instructions on connecting a conventional radio receiver are given in section 6.  Connecting a 
receiver is not necessary in order to use Sigmira with .wav files.  See section 8, Networked 
Receivers.

3 Controls and Displays

3.1 Waterfall Display

The waterfall display displays a time history of the signal spectrum.  It is also used to select which
signal to demodulate.

The waterfall display is the bottom third of the window. Higher frequency components are 
displayed to the right.  The strengths of the frequency components are represented by brightness 
or color.  The display shifts down with time so that the most recent signal content is displayed 
upper most.  The display has a frequency scale along the top and a time scale along the left edge.

Figure 1 - Waterfall Display
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The frequency scale is in Hz and is relative to the center tuning frequency.  The frequency span of
the waterfall display is adjustable with the "Spectrum" "Width" controls.  There are also controls 
to pause the waterfall and to adjust the scaling of the display intensity level.

The scroll rate is adjustable.  Move the cursor into the time scale on the left and roll the mouse 
wheel.

The waterfall display is also used to select which signal to demodulate.  CW, PSK31, S4285, etc. 
are all narrow band transmissions.  They show as bright vertical bands in the waterfall display. 
PSK31 and CW transmissions show as single vertical bands.  An FSK transmission shows as a 
pair of vertical bands.  Multiple transmissions may be present on the input and in the waterfall 
display at one time.

Select the particular transmission to be demodulated by right-clicking on it in the waterfall 
display.

A little red triangular pointer in the frequency scale indicates the frequency selected for 
demodulation of the signal.  When the 'Lock Center' option is off the select frequency is shifted to
the center of the display.  When the 'Lock Center' option is on the display center frequency does 
not change and the red triangle moves to the selected frequency.

When in PSK31 or CW mode right-click directly on the signal.  When in FSK mode two triangles
are shown on the frequency scale.  The triangle to the right is red and corresponds with the 'Mark' 
frequency.  Right-click on the higher frequency column of the desired signal, i.e. the mark 
frequency. (It is easier to click on a signal when the displayed spectrum width is narrower.)

With the sound card or wave file selected as the source the maximum waterfall width is 10 kHz.

3.2 Spectrum Display

The spectrum display displays a plot of signal level vs. frequency.  

Figure 2 - Spectrum Display

There is a signal power scale at the left of the display.  When SDR-IQ is selected as the source the
scale is in dBm at the antenna input.  When the source is the sound card or a wave file the scale is 
in dB relative to the full scale internal sample representation.
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Tuning/frequency selection can be accomplished by right-clicking on the spectrum display just as 
on the waterfall display.

The base level of the display can be adjusted by rolling the mouse wheel while the cursor is in the
spectrum display.

3.3 Rx Text Display

The received text display pops up whenever one of the CW, PSK31, FSK, RTTY, or S4285 mode 
buttons is clicked.  

Figure 3 - Rx Text Window

The demodulated text of the selected transmission appears here.  (RTTY, PSK31, CW, STANAG 
4285, FSK, HFDL, and FLEX pager transmissions all originate as text type messages.)

Received text can be saved by following the File=>Save or File=>Save As menu dialogs. The text
display can be cleared by selecting the Edit=>Clear Text menu item, Text can be selected with the
mouse cursor and copied to the clipboard with Ctrl-C. (You may have to temporarily switch to a 
non-text demodulation mode [e.g. AM] so that the text stops moving while you do the selection.)

Whenever the demodulation mode is changed or the frequency is changed by 100 Hz or more a 
note is displayed in the Rx Text window.
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3.3.1 File->Save/Save As

Selecting Save or Save As brings up a dialog window that can be used to save the received 
demodulated text to a windows text file. The entire text from the Rx Text window is saved to the 
file.   The default name of the destination text file at start-up is 'untitled'.  The name can be 
changed with the 'Save As' selection.  Sigmira remembers any such change to the destination file 
name.  Subsequent 'Save' selections will write to the remembered destination file name.  Any save
to a file overwrites the previous contents if any.

3.3.2 Edit Menu

The Sigmira Rx Text window Edit menu has one entry, 'Clear text'.  Selecting 'Clear text' clears 
the received text display.

3.4 Phase Plane Display

The Phase Plane display can be brought up by selecting View->Phase Plane from the main 
window menu bar.  

Figure 4 - Phase Plane Window

The phase plane displays the time varying phase and amplitude of the signal.  The phase is 
relative to the tuning VFO.  At any instant in time the phase and amplitude of the signal are 
represented by a point in the display.  The amplitude is represented by the distance of the point 
from the center of the display.  The phase is represented by the angle of the point around the 
center.  Positive angle is counter-clockwise.  To the right is 0 degrees, up is 90 degrees, left is 180
degrees, and down is 270 or -90 degrees.  If a constant amplitude pure carrier of the same 
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frequency and phase of the VFO were being received it would be displayed as a dot to the right of
the center.  If the carrier were 1 Hz higher in frequency than the VFO the dot would revolve 
around the center counter-clockwise making one revolution per second.

A Binary Phase-Shift Keying (BPSK) High Frequency Data Link (HFDL) signal is shown in the 
figure above.  In the absence of noise and distortion a BPSK signal would appear as two dots 180 
degrees opposite each other with a line between them.  Distortion in the radio wave propagation 
causes the wiggling seen above.

The phase plane display is appropriate for viewing phase modulated signals such as PSK31, 
STANAG 4285, HFDL, etc.  Certainly it is also of interest out of general curiosity.  And it is also 
useful as a tuning and calibration indicator. 

An AM signal will generally appear as a line segment radiating from the center of the display.  If 
Sigmira is tuned exactly to the carrier frequency the line will be stationary and not revolve around
the center.  As mentioned above, if the signal is 1 Hz higher in frequency the line will revolve 
around the center counter-clockwise at 1 Hz.  This makes the phase plane a sensitive tuning 
indicator.  This is useful in calibrating the SDR-IQ.  See section 3.16.1.

The phase plane display is functional in all of Sigmira's demodulation modes.

In the AM, USB, and LSB modes the Demod Width setting is effective.  In those modes the 
signal content on both sides of the tuning frequency are processed into the phase plane display 
(i.e. USB and LSB modes do not cut off the sidebands in the phase plane display.)  It is 
appropriate and advantageous to set the Demod Width to a minimum which includes the signal of 
interest and excludes outside noise.  The Demod Width is the one-sided width.  So, if one is 
viewing a phase modulated signal with a two-sided (total) width of 2 kHz, the Demod Width 
should be set to 1 kHz.

In the PSK31 and S42285 modes the Demod Width setting is not important.  In addition, the 
demodulator locks phase with the signal and that is reflected in the phase plane display.  With a 
good PSK31 signal the displayed phase will bounce between approximately 0 degrees and 180 
degrees.

3.5 Modes

The Mode refers to the type of signal, AM, USB, LSB, CW, STANAG 4285, FLEX, etc.  The 
mode setting selects which type of signal the program demodulates.  The currently active mode is 
selected by clicking on the particular Mode 'radio button' in the 'Mode' group in the upper left 
corner of the program window.
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Figure 5 - Mode

3.5.1 AM

The AM is the usual Amplitude Modulation that everyone is familiar with.  AM is typically used 
to send audio signals.   The "AM broadcast band" (also know as MW or "medium wave") ranges 
from 520 to 1610 (1710 in the US) kHz.  International short-wave broadcasters operate on several
bands in the 3 to 30 MHz range.  AM can also be described as double sideband (DSB) with 
carrier.  AM signals can have various widths, 10 kHz and 20 kHz being common.

Figure 6 - Typical AM Signal

To tune in an AM transmission click on the AM radio button in the Mode group in the upper left 
corner of the Sigmira window.  Then select the particular transmission to demodulate by right-
clicking on it in the waterfall display. 
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For the optimum signal to noise ratio the demodulation width should be adjust to match the 
signal.  See section 3.8 "Demodulation Width".  For the signal in the above figure a demodulation
width of 10 kHz would be appropriate.

AM broadcast signals have modulation bandwidths of 5 or 10 kHz, typically. 

The squelch control can be used to reduce response to noise.  See section 3.11, Squelch Control. 

3.5.2 USB

USB stands for Upper Sideband.  It is one of the two single sideband (SSB) modes.  SSB is 
normally used to send audio signals.  Normal amplitude modulation produces two sidebands, one 
on each side of the carrier.  The audio information is in the sidebands and the sidebands are mirror
images of each other.  SSB was developed to be more efficient than AM.  Only one sideband is 
transmitted, thus SSB signals are narrower.  There are two advantages to that.  1. More signals 
can be packed into the same bandwidth and 2. the reduced receiver bandwidth allows less noise in
with the signal.  Typically the carrier is suppressed too which is an additional power savings at 
the transmitter.  The down side to SSB is that demodulating the signal is more complex.  The 
receiver must either reinsert a locally generated approximation of the carrier or use a complex 
signal and the Hilbert transform.  And tuning is critical.  If the receiver is tuned to high or low in 
frequency the resulting audio is shifted up or down giving what is described as a Donald Duck 
sound.

Since an AM signal has two sidebands there are two choices as to which sideband to transmit for 
SSB.  Thus Upper Sideband (USB) and Lower Sideband (LSB).  Hams make extensive use of 
SSB.  By convention they use LSB below 10 MHz and USB above 10 MHz.

The USB or LSB receive modes can sometimes be used for improved reception of a regular AM 
signal.  If there is an interfering signal that affects one sideband of an AM signal more than the 
other one can use the appropriate SSB mode to demodulate the sideband suffering the least 
interference.  Another case where SSB receive mode can be used to advantage on an AM signal is
when the AM signal is experiencing severe frequency selective fading.  In instances where the 
carrier specifically is faded out the sound can be particularly distorted using the normal AM 
demodulation mode.  Switching to SSB significantly reduces the distortion because SSB 
demodulation does not use the carrier.
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Figure 7 - Upper Sideband (USB)

3.5.3 LSB

LSB stands for Lower Sideband.  It is the flip side of Upper Sideband, USB.  See USB above.

3.5.4 PSK31

PSK31 is a narrow-band character-based modulation mode used by hams for interactive long 
distance communication in the HF bands.  PSK31 employs Binary Phase Shift Keying (BPSK), 
Huffman coding, and a low baud rate.  Those features are particularly suited to the HF bands 
which offer over-the-horizon and world wide propagation with the challenges of ionospheric 
fading and limited frequency resources.
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Figure 8 - PSK31 Signals

The popularity of PSK31 rather reduced now in 2020. PSK31 signals were regularly found at 
7070 kHz and 14070 kHz.  The lower frequency, 7070 kHz, is more active evenings and the 
higher frequency is more active middays. A PSK31 signal appears as a bright column in Sigmira's
waterfall display.  Figure 8, above, is an example of the appearance of PSK31 signals.  That 
example is from a particularly active period but it is common that there are many signals visible at
one time.  The narrowband nature of PSK31 signals allows many signals to be placed close 
together, even within the passband of a short-wave communications receiver, and thus be visible 
at the same time at one receiver frequency setting.

To demodulate a PSK31 transmission click on the PSK31 radio button in the Mode group in the 
upper left corner of the Sigmira window.  Then select the particular transmission to demodulate 
by right-clicking on it in the waterfall display.  The demodulated text will appear in the Rx Text 
window.

Sigmira uses a narrow filter to separate the selected transmission from the rest of the input.  The 
signal strength indicator indicates the strength of the filtered signal.  The waterfall display 
continues to display the entire input.

The SDR-IQ has something of a "0 Hz birdie".  Samples from the SDR-IQ have a DC offset that 
shows as a peak or faint line at the center of the spectrum/waterfall.  It can interfere with PSK31 
demodulation (when 'Lock Center' is off).  The offset can be minimized with the 'DC Comp.' 
feature described below.  However in some cases it may still be advantageous to tune slightly off 
from the PSK31 signal (so that it is not at the center of the spectrum), turn 'Lock Center' on, and 
then tune directly on the PSK31 signal. 
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The squelch control can be used to reduce response to noise.  See section 3.11, Squelch Control. 

3.5.5 RTTY

RTTY (Radio Teletype) is a narrow-band character-based modulation mode used by hams for 
interactive long distance communication in the HF bands. (Note that the Sigmira RTTY mode is 
specifically oriented to the ham FSK signal.  For the general FSK demodulation mode see the 
FSK mode section, below.) RTTY employs Frequency Shift Keying (FSK) modulation, "Baudot" 
coding, and a low baud rate.  Those features are suited to the HF bands which offer over-the-
horizon and world wide propagation with the challenges of ionospheric fading and limited 
frequency resources.  RTTY is one of the earliest forms of digital modulation having originated 
probably before the 1940s.  As such it doesn't include the more modern features of Huffman 
coding and phase shift keying that PSK31 does.  

Figure 9 - RTTY Signal

RTTY signals can generally be found from 7080 kHz to 7100 kHz and 14080 kHz to 14100 kHz. 
The lower frequency range is more active evenings and the higher frequency range is more active 
middays.  (When using an external receiver connected to the sound card input set the receiver to 
USB mode.)

The frequency shift for RTTY signals is 170 Hz.  The higher frequency is the "mark" frequency 
and the lower frequency is the "space" frequency.  The baud rate is 45.45.  A RTTY signal 
appears as a pair of bright column in Sigmira's waterfall display.  Figure 9, above, is an example 
of the appearance of a RTTY signal.
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To demodulate a RTTY signal click on the RTTY radio button in the Mode group in the upper 
left corner of the Sigmira window. When in RTTY mode two triangles are shown on the 
frequency scale.  The triangle to the right is red and corresponds with the 'Mark' frequency.  
Right-click on the higher frequency column of the desired signal, i.e. the mark frequency. (It is 
easier to click on a signal when the displayed spectrum width is narrower.) The demodulated text 
will appear in the Rx Text window.  (When using a conventional receiver with Sigmira for RTTY
demodulation make sure the receiver is in USB mode.)

Sigmira uses a narrow filters to separate the selected transmission from the rest of the input.  The 
signal strength indicator indicates the strength of the filtered signal.  The waterfall display 
continues to display the entire input.

The squelch control can be used to reduce response to noise.  See section 3.11, Squelch Control. 

3.5.6 FSK

FSK (Frequency Shift Keying) is a mature, uncomplicated "digital" mode.  It is generally used for
character-based communication.  It originated before the 1940s and is still used by military, 
government, and private maritime entities for long-haul, over-the-horizon communication on the 
HF bands.  Hams also use FSK.  Sigmira has a separate RTTY mode that is specifically oriented 
to the ham FSK mode.

Sigmira's FSK mode can also be used to demodulate SITOR-B signals. SITOR-B is 170 Hz shift, 
100 baud, CCIR 476 character set.

There are over a dozen entries for FSK signals in the Sigmira signal database. There are many 
FSK signals that run almost constantly. They are most commonly 850 shift and 50 or 75 baud.  
They are also typically encrypted.  Some of the stronger signals received in southern California 
are 5345, 7593, 9085, and 14436.3 kHz (center). (We're in a sunspot low in 2020 so these HF 
signals are not so prominent.)

At least two of the SITOR-B signals heard in southern California are from NMC.  They consist of
maritime weather information (unencrypted).  They are at 8416.5 and 12579 kHz (center).

To demodulate an FSK signal click on the FSK radio button in the Mode group in the upper left 
corner of the Sigmira window. When in FSK mode two triangles are shown on the frequency 
scale.  The triangle to the right is red and corresponds with the 'Mark' frequency.  Right-click on 
the higher frequency column of the desired signal, i.e. the mark frequency. (It is easier to click on 
a signal when the displayed spectrum width is narrower.) The demodulated text will appear in the 
Rx Text window.  (When using a conventional receiver with Sigmira for FSK demodulation make
sure the receiver is in USB mode.)

Sigmira's FSK mode offers user selectable shift, baud rate, mark/space inversion, and source 
format.

The FSK Control window is displayed whenever the FSK mode is selected (from the mode 
buttons in the upper left corner of the main window) or when called up via the View menu, 
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View=>FSK Control, also in the upper left corner of the main window.  The FSK Control 
window appears as below:

   

Shift
The Shift radio buttons allow the demodulator to be set to match the frequency shift of the 
received signal. The shift of the received signal is most easily observed when the displayed 
spectrum width is set at lower values, i.e. 25 kHz or less.  When in the FSK mode two triangles 
are shown on the frequency scale.  They correspond to the 'mark' and 'space' frequencies.  
(Typically the higher frequency is the mark frequency.)  Select the shift so that the separation of 
the triangles matches the separation of the displayed columns of the received signal.  Then right-
clicking on the mark column in the waterfall display tunes the demodulator so that the red triangle
is over the mark frequency and the yellow triangle is over the space frequency.  Most signals are 
either 170 or 850 shift.  The FSK Control window offers preset buttons for several known shift 
values.  In addition the far right shift button allows the selection of a shift value that can be 
entered by the user.

Baud

The Baud radio buttons allow the demodulator to be set to match the baud rate of the received 
signal. Most 850 shift signals are either 50 or 75 baud.  Amateur RTTY signals are 45.45 baud 
(170 shift).  SITOR-B signals are 100 baud (170 shift).  Selection of the correct baud rate can be 
verified in the eye diagram described below. The FSK Control window offers preset buttons for 
the common baud rates.  In addition the button on the far right allows the selection of a rate that 
can be entered by the user.

Mark/Space Invert

The Mark/Space Invert checkbox allows the swapping of which frequency is interpreted as mark 
and which as space.  Normally the higher transmitted frequency is mark.  A few stations transmit 
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mark as the lower frequency.  In addition, when using a conventional receiver it is common for 
the receiver to switch to lower sideband mode below 10 MHz.  That swaps the mark and space 
frequencies.  The Mark/Space Invert checkbox can be used to adapt the demodulation to an 
inverted sender or to a lower sideband swap.

Differential

One way to avoid sensitivity to which of the two frequencies is the 'Mark' and which is the 'Space'
is to send the signal 'differentially'. With a differential signal a change from one frequency to the 
other would be considered a mark (or a '1') and no change would be considered a space (or a '0'). 
This yields the original intended symbol values even if the two frequencies somehow become 
reversed somewhere in the signal path. The 'Differential' checkbox enables this interpretation. The
'Invert' checkbox still works in conjunction with the Differential feature. Invert changes whether a
frequency change is considered a '1' vs a '0'. I don't know of any particular FSK signal that is 
differential but Sigmira is prepared for the possibility. (PSK31, which is not an FSK signal, is an 
example of a differential signal.)

Source Format 

The Source Format radio buttons allow one to select the final interpretation of the data for display
in the Rx Text window.

     Binary

The 'Binary' mode is basically no interpretation.  The individual bits are displayed.  The binary 
mode is appropriate for viewing encrypted transmissions because the encryption conceals the 
original source format. The binary mode is also useful in assessing unknown signals and looking 
for patterns that indicate the actual format.  The regular pattern of start and stop bits is usually 
apparent when viewing ITA2 data in binary mode.

     ITA2 (Baudot)

The 'ITA2' mode prints data formatted at the source in the 5-bit start stop serial ITA2 alphabet.  
(ITA2 is sometimes referred to as "Baudot".)

     ASCII

The 'ASCII' mode prints data formatted at the source in the common 7 or 8-bit start stop serial 
format.  The control window also includes options for the number of bits, parity bits, and stop 
bits.  Those settings are only effective in the ASCII mode. I've never seen any HF signal encoded 
in ASCII.

     CCIR476

The 'CCIR476' format is used by SITOR-B and NAVTEX.  (In CCIR476 characters are seven bit 
long with exactly four '1' bits per character.  Each character is sent twice with the repeated 
characters being interleaved and delayed by five characters.)

LTRS/FIGS

The LTRS and FIGS button allow the LTRS/FIGS state of the demodulator to be manually 
changed.  Both ITA2 and CCIR476 use a LTRS/FIGS state to extend the range of characters that 
may be sent.  The five bits of an ITA2 character and the seven bits of a CCIR476 character 
basically only allow for about 32 different characters.  "LTRS" and "FIGS" control characters are 
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used to tell the demodulator to switch back and forth between two tables of meanings for the 
transmitted character.  When in the LTRS state '10000' (ITA2) means 'T' and when in the FIGS 
state '10000' means '5'.  The demodulator must track the LTRS/FIGS state.  Noise, interference, 
and fading can cause the demodulator to miss or receive false LTRS and FIGS control characters 
and thus lose track.  In that case a string of inappropriate letters or figures will be observed in the 
received text display.  If the demodulator is erroneously in the FIGS state clicking the LTRS 
button forces the demodulator back to the LTRS state.  Likewise the FIGS button forces the 
demodulator to the FIGS state.  The LTRS and FIGS buttons in the FSK Control window are also 
effective when Sigmira is in RTTY mode.

The eye diagram display is shown below.

The eye diagram allows the signal quality and the demodulated bit timing to be observed.  With a 
good quality signal and the correct baud rate selected the diagram appears as above.  There is one 
complete "eye" that is centered and "open".  The signal zero-crossing points are at the ends of the 
green line.    Note that ITA2 and ASCII signals can have irregular bit timing.  The functioning of 
the eye diagram is adjusted to compensate for that when the ITA2 or ASCII source format is 
selected.

Two recorded examples of FSK signals are included in the Sigmira package.  They can be found 
at <sigtools_install_root>/examples/fsk_8r432_090418_1236_ksm.wav and 
<sigtools_install_root>/examples/sitorb_8r432_090418_1504_ksm.wav.  The FSK example is 
1000 Hz center, 170 shift, 45.45 baud, ITA2.  The SITOR-B example is 1000 Hz center, 170 
shift, 100 baud, CCIR476.  To demodulate the SITOR-B example open the .wav file using the 
"File" menu in the main Sigmira window.  (Refer to section 8 of this document for more details 
on opening .wav files.)  Set the tuning frequency to 1000 Hz in the frequency control of the main 
window.  (Section 3.8 can be referred to for more details on frequency setting.)  Select "FSK" in 
the "Mode" menu in Sigmira's main window.  Then in the "FSK Control" window select the 170 
Hz shift.  Select the 100 baud rate. The Mark/Space Invert box should be unchecked.  Set the 
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"Source Format" option to "CCIR476".  The decoded text should appear in the Rx Text window 
as shown below. 

The squelch control is usable in the FSK mode. 

3.5.7 CW

CW is old fashioned Morse code over radio. "CW" stands for "continuous wave". It is a historical 
term arising from the fact that the very first transmitters of a hundred years ago could not always 
produce the long 'dash' sound.

CW is "low tech".  It requires the least hardware.  All one needs to transmit a CW signal is a radio
frequency generator with an on-off switch. That simplicity plus a nostalgia factor account for the 
longevity CW. CW does place greater demands on the receiver software, which has traditionally 
been implemented in a human being.

Figure 10 - A CW Signal
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Interestingly, Morse code incorporates a basic concept that has been most recognized in the more 
modern Huffman coding.  Huffman codes were invented some one hundred and twenty years 
later.  In both codes the most common characters are mapped to the shortest transmit sequences.

CW signals can generally be found from 7000 kHz to 7070 kHz and 14000 kHz to 14070 kHz.  
The lower frequency range is more active evenings and the higher frequency range is more active 
middays.

A CW signal appears as a bright column in Sigmira's waterfall display.  To demodulate a CW 
signal click on the CW radio button in the Mode group in the upper left corner of the Sigmira 
window.  Then select the particular transmission to demodulate by right-clicking on the signal in 
the waterfall display.  Initially Sigmira has to adapt to the rate at which the code is being sent.  
CW can be sent at a rate anywhere from 3 words per minute to 60 words per minute.  While 
adapting Sigmira will typically print a number of 'E's in the Rx Text window.  With a decent 
signal Sigmira will adapt to the correct speed within 10 seconds

Sigmira uses a very narrow filter to select the CW transmission out of the total input.  The signal 
strength indicator indicates the strength of the filtered signal.  The waterfall display continues to 
display the entire input.

(The CW filter is fixed at 50 Hz and is perhaps too narrow for some uses. If the automatic to-text 
deciphering is not need then CW can be listened to in the USB mode.  A selectable range of CW 
filters will be added to a future version of Sigmira.)

Most of the SDR receivers have something of a "0 Hz birdie".  Samples from the SDR have a DC 
offset that shows as a peak or faint line at the center of the spectrum/waterfall.  It can interfere 
with CW demodulation (when 'Lock Center' is off).  The offset can be minimized with the 'DC 
Comp.' feature described below.  However in some cases it may still be advantageous to tune 
slightly off from the CW signal (so that it is not at the center of the spectrum), turn 'Lock Center' 
on, and then tune directly on the CW signal. 

In CW mode the 'Squelch' control can optionally be used to set the signal level that is considered 
as "key down".  When the signal level is above the squelch level it is considered a "key down" 
period, i.e. part of a 'dit' or a 'dah'.  When the signal level is below the squelch level it is consider 
to be a "key up" interval, i.e. between a 'dit' or 'dah'.  But it is not necessary that the best setting 
for this control be selected manually.  If the squelch level is set at 0, at the bottom, the program 
automatically adjusts to what it calculates is the best level.
Also see section 3.11, Squelch Control. 

3.5.8 STANAG 4285

STANAG 4285 is a digital modulation mode designed by NATO for HF radio communications.  
It appears to be used mostly for long haul broadcast communication by various navies and 
maritime organizations.  STANAG 4285 is a 2400 baud, 8-PSK signal.
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The symbol rate is always 2400 symbols per second but various modulation options result 
in data rates from 75 to 3600 bps.  The 2400 sps rate and PSK modulation result in a 
bandwidth of about 2400 Hz.  Thus STANAG 4285 is wider than many HF data signals 
but still fits in the bandwidth of a typical voice signal.  The signal has a 256 symbol frame 
structure which includes an 80 symbol synchronization pattern and three 16 symbol 
reference patterns.  The sync and reference patterns along with 8-ary symbol scrambling 
facilitate adaptive channel equalization.  Channel equalization is advantageous for a high 
data rate signal in the HF band considering the associated ionospheric fading.  The sync 
pattern also facilitates Doppler adaptation as well as frame synchronization and symbol 
rate adaptation.

STANAG 4285 provides for forward error correction (FEC).  FEC adds redundancy to the
data such that the receiver can detect and generally correct errors in the received data.  In 
STANAG 4285 FEC is implemented in a rate 1/2, constraint length 7 convolutional code 
and interleaver.  The convolutional code effectively adds as many "parity" bits as there are
data bits, thus the source data rate is 1/2 the coded data rate.  Decoders for convolutional 
codes are less effective against bursts of errors.  Bursts of errors are common in radio 
channels so an interleaver is typically employed along with a convolutional code.  The 
interleaver shuffles the order of the data bits.  A deinterleaver in the receiver reverses the 
interleaving.  The errors of a bursts of errors caused by the radio channel are spaced out by
the deinterleaver in the receiver.

The length of the interleaver in STANAG 4285 is a selectable option.  Two nominal 
values are available, "short" and "long".  The longer interleave is more resistant to channel
noise bursts and fades.  The length of the interleaver also corresponds with a real time 
delay in the data becoming available at the output of the demodulator.  The "short" 
interleave corresponds with a delay of about 1 second.  The "long" interleave corresponds 
with a delay of about 10 seconds.  So if the "long" interleave option is selected any 
disturbance or change in the received signal won't be evident until 10 seconds later.

The STANAG 4285 specification includes an optional "message mode".  The message 
mode is something of a digital squelch.  The message mode specifies a "start of message" 
bit pattern (SOM) and an "end of message" bit pattern (EOM).  When the message mode 
is selected the receiver is only to output data after a SOM is detected and before the next 
EOM is detected.  In this observer's opinion the message mode is something of a 
misfeature.  There are other less error prone methods of achieving the same result and no 
known actual users of  STANAG 4285 use the message mode.

Sigmira employs an adaptive decision feedback equalizer (DFE) for channel equalization 
and a Viterbi decoder for the convolutional code.

STANAG 4285 transmitters have typically used a modem that produces an audio signal which is 
then the input to an USB transmitter.  The carrier or center of the audio band STANAG 4285 
signal is specified as 1800 Hz.  The commonly quoted frequency for a STANAG 4285 radio 
signal is the tuning of the USB transmitter.  So the actual center of the STANAG 4285 RF signal 
is 1800 Hz higher than the quoted frequency.  Sigmira tuning is oriented to the center of the 
signal.  When using Sigmira with the SDR-IQ the frequency setting should be the commonly 
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quoted frequency plus 1800 Hz.  When using Sigmira with a conventional receiver tune the 
receiver to the commonly quoted frequency, USB mode, and set Sigmira to 1800 Hz.

Monitoring from southern California STANAG 4285 signals are often found around 6500 kHz 
and 8500 kHz.  They are more common and stronger at night.  A couple common signals are at 
6400.5, 8490, and 8554.4 kHz (center).  All observed signals have data rates of either 300, 600, or
1200 bits per second.  A slight majority operate at 600 bits per second.  All of them operate with 
the long interleave option.  

Most of the observed signals appear to be encrypted.  (The bit autocorrelation is flat and the run 
length statistics are the same as a Bernoulli process.)  But there are signals transmitted in the 
clear.  The French navy has been broadcasting several test signals in the clear for some time now. 
Examples are 8480.3, 8626.8, and 8647.8 kHz (center).  The 8626.8 signal is at 600 bps.  The 
others are 300 bps.  All use the long interleave.  They use the ITA2 alphabet.

The spectrogram of a STANAG 4285 signal is given in Figure 11, below.  This is not a 
particularly strong signal.  Significant fading is also evident.  Even so, good copy was obtained 
from this signal.

Figure 11 - STANAG 4285 Signal Spectrogram

To demodulate a STANAG 4285 transmission click on the S4285 radio button in the Mode group 
in the upper left corner of the Sigmira window.  The Rx Text window and STANAG 4285 
Control window should appear.
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Figure 12 - STANAG 4285 Control Window

In the upper part of the control window are two indicators, the Sync indicator and the FEC 
Quality indicator.  The Sync indicator illuminates green when Sigmira locks on to the 
synchronization of a STANAG 4285 signal.  (Since the signal energy from 80 out of every 256 
symbols contributes to sync detection it is possible detect sync even from signals which are too 
poor to yield good payload data.)  The FEC Quality indicator is a thermometer type graph that 
indicates the quality of the demodulated data before the Viterbi decoder.  If the indicator is above 
the 70% level the Viterbi decoder is able to correct virtually all errors.  Good copy can still be 
obtained in the 50 to 60% range.  (Note that the FEC Quality indicator is after the deinterleaver.  
If the interleave setting is changed to 'Long' or if the tuning is changed there will be a 10 second 
delay before the FEC Quality indicator gives a true indication.)

The Data Rate radio buttons in the control window allow the selection of the signal's expected 
data rate.  It appears that virtually all real signals are either 300, 600, or 1200 bits per second.  For
an unknown signal one can determine the data rate by switching between the rates and observing 
the FEC Quality indicator.  The FEC Quality indicator will be near zero for the incorrect rate.  
(Setting the data rate to a value above 600 bps also affects the deinterleaver.  After changing the 
data rate to a value above 600 or back again one must wait the interleaver delay, 10 seconds for 
the 'Long' interleave, before the FEC Quality indication catches up.)

The Interleave radio buttons in the control window allow the selection of the signal's expected 
interleave.  It appears that virtually all real signals use the long interleave.  The interleave results 
in a real time delay through the demodulator.  The short interleave results in a delay of about 1 
second.  The long interleave results in about 10 seconds.  Changing the interleave setting resets 
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the deinterleaver and the interleave delay must pass before good data works its way through the 
deinterleaver again.  The interleaver is also reset if the data rate is changed to or from any value 
above 600.

The Source Format radio buttons allow one to select the final interpretation of the data for display
in the Rx Text window.  The 'Binary' mode is basically no interpretation.  The individual bits are 
displayed.  The binary mode is appropriate for encrypted transmissions because the encryption 
conceals the original source format.  Most signals appear to be encrypted.  The binary mode is 
also useful in assessing unknown signals and looking for patterns that indicate the actual format.  
The regular pattern of start and stop bits is quite apparent when viewing ITA2 data in binary 
mode.  The 'ITA2' mode prints data formatted at the source in the 5-bit start stop serial ITA2 
alphabet.  (ITA2 is sometimes referred to as "Baudot".)  Several real broadcast test signals have 
been observed using ITA2.  The 'ASCII' mode prints data formatted at the source in the common 
7 or 8-bit start stop serial format.  The control window also includes options for the number of 
bits, parity bits, and stop bits.  Those settings are only effective in the ASCII mode. (But I've 
never seen a STANAG 4285 signal that used ASCII.)

The Message Mode check box controls the STANAG 4285 specified optional "message mode".  
When in the message mode the printing of demodulated data begins when the specified "start of 
message" bit pattern is detected and ends when the specified "end of message" bit pattern is 
detected.  When not in message mode all data are printed.  Message mode filtering is never 
applied when the 'Binary' Source Format is selected.

The Sync Detect radio buttons allow one to choose between two signal synchronization detector 
settings.  With the 'Optimal' setting the sync detector is optimized for stable synchronization and 
minimal errors for both good and marginal signals per the STANAG 4285 specification.  The 
'Quicker' setting modifies the sync detector to synchronize instantly when given a good quality 
signal.  Instant synchronization is not part of the mission of STANAG 4285.  Generally the Sync 
Detect option should remain set to Optimal.

Figure 13 - Phase Plane Display for STANAG 4285 Signal
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Figure 13 above illustrates the phase plane display when a high quality STANAG 4285 signal is 
being received.  The dots correspond to the received symbols.  The 8-PSK nature of the signal is 
quite clear.  Note that at the lower data rates, including 300 and 600 bps, good copy is possible 
even with signals so noisy and distorted that an 8-PSK constellation is hardly recognizable in the 
phase plane.  (The constellation in the phase plane is distinctly eight-pointed only when the signal
is greater than the noise floor by 15 dB or more.)

A recorded example of a STANAG 4285 signal is included in the Sigmira package.  To 
demonstrate Sigmira's STANAG 4285 operation begin by opening the example STANAG 
4285 .wav file.  The example is in the "examples" directory and is named 
"s4285_081020_2200_8r6268_600lita2_fnav_fum.wav".  Wave files are opened using the "File" 
menu in the main Sigmira window.  (Refer to section 8 of this document for more details on 
opening .wav files.)  Set the tuning frequency to 1800 Hz in the frequency control of the main 
window.  (Section 3.8 can be referred to for more details on frequency setting.)  Select "S4285" in
the "Mode" menu in Sigmira's main window.  Then in the "S4285 Control" window select the 
"600" bps data rate.  The "Interleave" option should also be set to "Long" (which is the default).  
Set the "Source Format" option to "ITA2".  The "Message Mode" check box should be unchecked
(which is the default).  The signal will then be demodulated and wend its way through the 
deinterleaver and Viterbi decoder.  After about 10 seconds text as shown below in Figure 14 will 
appear in the Rx Text window.

Figure 14 - Text of the French Navy FUM STANAG 4285 Test Signal

3.5.9 HFDL

HFDL is a digital modulation mode used mainly by transoceanic aircraft.  It was designed for and
is employed on the HF bands because HF signals propagate over the horizon (unlike VHF, UHF, 
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etc.).  HFDL messages often contain information such as aircraft ID, position (latitude and 
longitude), equipment status, and weather.

HFDL stands for High Frequency Data Link.  It is specified in the document ARINC 635-3 by 
Aeronautical Radio, Inc.  Generally HFDL is an 1800 baud BPSK signal.  Occasionally it is also 
4PSK or 8PSK.

The known frequencies on which HFDL is used are in the included Sigmira signal database.  (See
section 4 about the signal data base.)  The frequencies can also be found in the internet.  The 
commonly quoted frequencies are the "dial" frequencies.  The center of the HFDL signal, i.e. the 
carrier, is 1440 Hz higher than the dial frequency.  When using Sigmira with the SDR-IQ tune to 
the center frequency, i.e. the dial frequency plus 1440 Hz.  (The entries in the signal database are 
the center frequencies.)  When using Sigmira with a conventional receiver tune the receiver to the 
commonly quoted frequency, USB mode, and set Sigmira to 1440 Hz.

The spectrogram of a couple HFDL signal bursts is given in the figure, below. 

HFDL Signals

To demodulate an HFDL transmission click on the HFDL radio button in the Mode group in the 
upper left corner of the Sigmira window.  The Rx Text window will appear.
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HDFL transmissions must be interpreted per the System Table.  Transmissions contain indexes 
which are used to look up ground station names and frequencies in the table.  At start up Sigmira 
obtains the system table by reading the file <sigtools_install_root>/bin/hfdl_system_table_51.txt. 
Version 51 is the current version as of November, 2020. Sigmira always reads the file with the 
highest version number. Updates are rare.  HFDL demodulation still works without the table.

A recorded example of an HFDL signal is included in the Sigmira package.  To demonstrate 
Sigmira's HFDL operation begin by opening the example HFDL .wav file.  The example is in the 
"examples" directory and is named "hfdl_example.wav".  Wave files are opened using the "File" 
menu in the main Sigmira window.  (Refer to section 8 of this document for more details on 
opening .wav files.)  Set the tuning frequency to 1440 Hz in the frequency control of the main 
window.  (Section 3.8 can be referred to for more details on frequency setting.)  Select "HFDL" in
the "Mode" menu in Sigmira's main window. The signal will then be demodulated and the 
decoded text in the Rx Text window as shown below.
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3.5.10 JSM   (Japanese Navy "Slot Machine")

JSM refers to a rather strange signal.  The consensus is that it is transmitted by the Japanese navy.
When one listens to it in USB mode it normally sounds like a continuous repetitive melody.  
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Some have likened the sound to that of a Las Vegas slot machine.  Thus the name, JSM, Japanese 
Slot Machine.

In California it is commonly best received after 22:00 (local) and up to the hour after sunrise 
(local) on 6.446 and 8.589 MHz (center).  It has also been heard on 4.154, 4.2325, 4.291, 6.251, 
6.418, 8.314, 8.7045 MHz (center).

A recorded .wav file example of the signal is include in the Sigmira distribution package.  It can 
be found at <sigtools_install_root>/examples/jsm_080904_0651_8r5888_example.wav.  Sigmira 
displays the example as shown below:

A recent live capture is shown below.
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Most of the time the signal is an exactly repeating melody.  It also includes an 11.4 Hz ticking 
sound.  The melody repeats every 5.6 seconds.  This is odd.  Information theory tells us that the 
more predictable a signal is the less information it contains.  This repeating signal contains 
basically no more than three pieces of information: a frequency, a phase, and a station ID.  
Occasionally the signal changes to become more chaotic and noise-like.  That is the information 
payload.  The melody intervals of the signal are called the "idle" time here.

The observed characteristics of the signal are consistent with a fixed (land based) broadcast to 
multiple, likely mobile, receivers over the horizon.  The signals run continuously without 
interruption.  The content of the signal on each of the various transmit frequencies appears 
identical.  There is never anything like a "reply".

The actual frequency of the nominal 8.589 MHz signal has been measured at 8.588997 MHz +/- 
0.5 Hz.  So the signal is not a top stratum frequency reference (such as NIST WWV).

A snapshot of the signal in the phase plane is shown in the image below.  (The "Demod Width" 
was set to 1 kHz.)
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Clearly it is a QPSK signal.

With some investigation the symbol rate was determined to be 1500.00 baud.  The regular ticking 
sound was found to be an exactly repeating sequence of symbols.  Clearly that serves as a channel
probe and frame synchronization pattern.  One tick sound period is here defined as a "frame".  
Frames were found to consist of 140 QPSK symbols.  So the frame rate is 10.71428 Hz.  The 
probe/sync pattern is 28 symbols which is one fifth the number of symbols per frame.  It is found 
that, during the repetitive melody idle time, the remaining symbols of a frame consist of four 
repetitions of another 28 symbol pattern.  So a frame appears to consist of five "blocks" of 28 
symbols.

During idle time there is a finite set of symbol patterns that appear in the blocks.  The patterns are 
designated here: ps, p0, p1, p2, p3, p4, p5, p6, p7, p8, p9, p10, and p11.  The "ps" pattern is the 
probe/sync pattern.  The rest are numbered roughly in the order of their frequency of occurrence.  
The "p0" pattern is most common.

The melodic idle time consists of an exactly repeating sequence of 64 frames.  A 64 frame 
sequence is called a "super frame" here.  The duration of a super frame is 5.973333 seconds.  The 
frame/block pattern of the idle super frame is presented in the following table. 

Idle Super Frame Structure

Frame 
Number

Block 0 
Pattern

Block 1 
Pattern

Block 2 
Pattern

Block 3 
Pattern

Block 4 Pattern

0 ps p10 p10 p10 p10

1 ps p10 p10 p10 p10

2 ps p10 p10 p10 p10

3 ps p0 p0 p0 p0

4 ps p8 p8 p8 p8

5 ps p8 p8 p8 p8

6 ps p8 p8 p8 p8
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7 ps p0 p0 p0 p0

8 ps p9 p9 p9 p9

9 ps p9 p9 p9 p9

10 ps p9 p9 p9 p9

11 ps p1 p1 p1 p1

12 ps p11 p11 p11 p11

13 ps p11 p11 p11 p11

14 ps p11 p11 p11 p11

15 ps p0 p0 p0 p0

16 ps p6 p6 p6 p6

17 ps p6 p6 p6 p6

18 ps p6 p6 p6 p6

19 ps p0 p0 p0 p0

20 ps p5 p5 p5 p5

21 ps p5 p5 p5 p5

22 ps p5 p5 p5 p5

23 ps p0 p0 p0 p0

24 ps p4 p4 p4 p4

25 ps p4 p4 p4 p4

26 ps p4 p4 p4 p4

27 ps p1 p1 p1 p1

28 ps p3 p3 p3 p3

29 ps p3 p3 p3 p3

30 ps p3 p3 p3 p3

31 ps p1 p1 p1 p1

32 ps p11 p11 p11 p11

33 ps p11 p11 p11 p11

34 ps p11 p11 p11 p11

35 ps p0 p0 p0 p0

36 ps p7 p7 p7 p7

37 ps p7 p7 p7 p7

38 ps p7 p7 p7 p7
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39 ps p1 p1 p1 p1

40 ps p3 p3 p3 p3

41 ps p3 p3 p3 p3

42 ps p3 p3 p3 p3

43 ps p0 p0 p0 p0

44 ps p0 p0 p0 p0

45 ps p0 p0 p0 p0

46 ps p0 p0 p0 p0

47 ps p1 p1 p1 p1

48 ps p0 p0 p0 p0

49 ps p0 p0 p0 p0

50 ps p0 p0 p0 p0

51 ps p1 p1 p1 p1

52 ps p0 p0 p0 p0

53 ps p0 p0 p0 p0

54 ps p0 p0 p0 p0

55 ps p0 p0 p0 p0

56 ps p1 p1 p1 p1

57 ps p1 p1 p1 p1

58 ps p1 p1 p1 p1

59 ps p0 p0 p0 p0

60 ps p0 p0 p0 p0

61 ps p0 p0 p0 p0

62 ps p0 p0 p0 p0

63 ps p1 p1 p1 p1

The choice of which frame in the super frame should be designated as frame 0 was somewhat 
arbitrary.  The numbering in the above table is used as the convention in this document.

The melody arises from the regular repeated simple patterns of symbols/phases.  The p10 pattern 
is all one phase.  So it produces a single tone.  The p11 pattern is also all one phase but 180 
degrees from p10.  The other patterns are somewhat more complex and result in different and 
multiple apparent tones. 
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There are times that the signal departs from the idle pattern and sounds more "noisy".  That is no 
doubt the data payload.  There are typically from 4 to 20 such data intervals per hour.  There 
seems to be no pattern to the minute of the hour at which data intervals begin.  The length of each 
data interval is an exact multiple of super frames.  At the end of a data interval the idle pattern 
resumes exactly in step and alignment as if there had been no interruption.  So there appears to be 
an underlying continuous 64-frame super frame structure to the signal.

It appears that each data interval begins at frame 31 or frame 32 in the super frame (by the frame 
numbering convention here).  Likewise the signal returns to idle at frame 31 or 32.  There appear 
to be several formats for data intervals.  They can roughly be characterized by the number of 
frames consisting of the fixed 'p' patterns (described above) that are mixed in with frames 
containing the data.  The data interval super frames generally consist of a repeating pattern of four
frames, some of which are random (data) symbols with the rest being the fixed patterns.  The 
number of data frames in those four frame groups can vary from one to four.  Data super frames 
in which less than all four frames of the four frame groups are data could be called "partial" data 
super frames.  Data super frames in which every frame contains data could be called "full" data 
super frames. The full data super frames are often preceded and followed by partial data super 
frames.

The suspected data symbols have been extracted and analyzed via autocorrelation.  The symbols 
were also converted to bits according to an expected Gray code.  The autocorrelations have been 
flat indicating that the symbols are further coded and/or encrypted.

The abrupt boundaries of the data super frames could expose evidence of convolutional coding or 
interleaving if used. Such evidence has not been obvious in the observed signals.

Sigmira uses the 'ps' block of the signal frames to accomplish carrier recovery, symbol 
synchronization, frame synchronization, and channel equalization.  The carrier reference phase 
was somewhat arbitrarily chosen such that the 'p10' pattern symbols are at 90 degrees.  (0 degrees 
is to the right in the Sigmira phase plane display.  90 degrees is up.)

Sigmira displays the demodulation results in the "Rx Text" window.  An example is given in the 
figure below.
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The above display resulted from demodulating the included example file:  
<sigtools_install_root>/examples/jsm_080904_0651_8r5888_example.wav.                               
(Set the tuning frequency to the center of the signal, which is 1000 Hz for the example file.)  The 
above display shows a transition from an idle interval to a "partial" data interval.  

The display consists of one frame per line.  

The first number in each line is the number of the frame in the super frame.  Note that Sigmira 
must first detect the idle super frame pattern in order to synchronize the frame numbers.  Before 
that occurs the frame numbers are displayed as "-1".

The rest of each displayed line/frame consists of either the recognized fixed group patterns or the 
raw QPSK symbols.  Each received 28 symbol group is compared to the fixed patterns.  If the 
group exactly matches a pattern, e.g. p0, p1, p2, etc., then the pattern number is displayed.  
Otherwise the 28 raw QPSK symbols are displayed.  The four possible QPSK symbols are 
translated to printable characters for display.  The translation is given in the following table.

Copyright 2008, 2011, 2016, 2020, 2021 Steven A. Harlow 35



Sigmira 1r13

QPSK Symbol Phase
(degrees)

Printed Character

0 '.'

90 '+'

180 'o'

270 '*'

It is likely that two bits are encoded in each QPSK symbol using a Gray code.  An arbitrary 
alignment could have been chosen and the resulting bits displayed in the Rx Text window.  Any 
misalignment of the code would have been manifest in every bit or every other bit being inverted 
from the correct sense.  Patterns in the data bits might be evident despite the inversions, but 
autocorrelations of the data so far have revealed no patterns.  It was decided to simply display the 
QPSK symbols in order to reduce the volume of characters sent to the display.

3.5.11 NFM

The NFM is narrowband frequency modulation. NFM is used for business, public service, ham, 
and GMRS voice communication. (Business and public service use is described as “Land Mobile 
Radio” [LMR].) It is primarily used on VHF and UHF.

NFM is similar to broadcast radio FM but much narrower in bandwidth and much lower in 
fidelity. NFM could be described as “toll-quality”, i.e. following the original standards for land 
line telephones. The frequency response is basically 300 to 3000 Hz. The TIA-603-E standard is a
good technical reference. NFM is very rarely used on HF.  
 
Sigmira's NFM mode is optimized for NFM as just described. So normally it is best to select the 3
kHz “Demod Width” when using NFM. (A wider 5 kHz width might give somewhat better sound 
quality with the NOAA weather broadcasts. The NOAA signals are a little wider than the 
standard 3 kHz. They can be found around 162.4 to 162.55 MHz.)

NFM can occasionally be heard in the 10m ham band around 29.6 MHz.  On rare occasions studio
links originating in Texas can be heard in southern California around 25.99 MHz and 26.19 MHz.
NFM is used in the 2 meter ham band, 144 to 148 MHz. NFM public service communications can
be heard around 856 MHz, 860 MHz, and various other frequencies.

An example of the appearance of an NFM signal in Sigmira's spectrum and waterfall displays is 
given in the figure immediately below.
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NFM Signal

The above display is from the included recorded example.  It can be found at 
   <sigtools_install_root>/examples/nfm_210817_0839_2m_keller_net_crop_08.wav
When playing the wave file set the demodulation mode to NFM, set the frequency to 10 kHz, and 
the demodulation width to 3 kHz. The recording is of a conversation on a 2m ham repeater.  
Looking at the spectrum, the central bars are from a Continuous Tone-Coded Squelch System 
(CTCSS).  The voice information is in the sidebands that extend further out from the center.

The Sigmira NFM implements the de-emphasis described in TIA-603-E and not the “75 s” or 
“50 s” associated with the common broadcast FM.

Set Sigmira's tuning frequency to the center of the signal.  It is not critical that the tuning be at the
exact center.

The squelch control is also functional in NFM mode.  (See section 3.11, Squelch Control.) 

3.5.12 FLEX Pagers

Pagers are palm sized radio receivers with which one can receive short text messages. The 
message might be the phone number of someone who would like you to call them back. Pagers 
peaked in popularity in the years just before cellphones became practical. There is still a solid 
niche for pagers. The short message function is still quite useful for communication with hospital 
staff and emergency responders. Pagers are also lower cost than cellphones.
 
POCSAG was the first technical standard for pagers. It is still dominant in Europe from what I 
understand. You can find POCSAG signals in the US but in my area 95% of the traffic is FLEX. 
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Most of the traffic I see is in the 929.0125 to 929.9875 MHz range with additional signals in the  
931.0125 to 931.9875 MHz range.

FLEX is transmitted as 2FSK and 4FSK. The shift frequencies are +/- 4800 Hz and +/- 1600 Hz. 
The symbol rates are 1600 baud and 3200 baud. Overall the signal has a width of about 24 kHz. 
Message information is formatted in blocks and frames in cycling time slots. A block is made up 
of 32 bit “code words”. The code words are made up of 21 data bits, ten BCH error correction 
bits, and one even parity bit.

There are various types of formatted messages such as “Numeric”, “Hex/Binary”, 
“Alphanumeric”, “Secure”, and “Short”. Each message is addressed to a specific pager. The 
“capcode” identifies the intended receiver. The capcodes are displayed with the messages in 
Sigmira's Rx Text window.

Some types of messages can be split across multiple frames. Messages are mostly not encrypted. 
A minority seem to be encrypted or in a special character set. Some transmitters seem to include 
extra optional features in the signal, such as a frequency reference preamble or a short frame 
ending tone.

The spectrogram of a FLEX pager signal is shown below.

FLEX Pager Signal Spectrogram

To demodulate FLEX transmissions click on the FLEX radio button in the Mode group in the 
upper left corner of the Sigmira window.  The Rx Text window will automatically appear. Tune 
to the approximate center of the signal. When receiving a live I/Q signal the tuning is not critical. 
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You can be as much as 12 kHz off center and Sigmira will adapt. It may take a couple frames to 
adapt. The “Demod Width” setting has no effect in the FLEX mode.

The squelch level can be adjusted so that the demodulator is active only when actual signal energy
is present. This is beneficial but not strictly necessary for demodulation. The squelch setting can 
also give a cleaner eye diagram display.

 

Eye Diagram for FLEX Pager Signal

The figure above illustrates the eye diagram display when a good quality FLEX signal is being 
received. The signal shown is a 4FSK, 3200 baud FLEX signal. There are four symbol times 
shown, left to right. The continuous stream repeatedly writes over the symbol times resulting in 
multiple symbols being painted in each position. The four FSK frequencies are represented in the 
vertical levels. The symbol immediately to the left of center contains the “A phase” and the “B 
phase”. The symbol immediately to the right contains the C and D phases.

A recorded example of a FLEX signal is included in the Sigmira package.  To play and 
demodulate the example click on File=>Open in the Sigmira main window. Then navigate to the 
examples directory. (My apologies that the file menu is unnecessarily complicated. It looks like 
you have to click 'bin' and then above that 'sigmira_1r13'. Then the 'example' directory appears.) 
Select the file “flex_929614_210816_1854_10kshift_selected.wav” in the 'examples” directory. 
Set the frequency control to 10 kHz. The recorded example is offset by 10 kHz. Don't forget to 
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select the FLEX mode in the main window. As the demodulation proceeds you will see the FLEX
messages displayed in the Rx Text window as in the image below.

FLEX Messages Demodulated from the Included Example Wav File

3.6 DC Comp.

The DC Comp. feature adapts to and cancels the DC offset in the samples from the various signal 
sources.

Figure 15 - DC Comp. Button

Samples from most SDR hardware boxes have a DC offset. The DC offset shows as a peak or 
faint line at the center of the spectrum/waterfall.  It can interfere with the demodulation of CW 
and phase modulated signals.  The offset varies with RF gain setting and tuning.
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In normal operation Sigmira subtracts an offset from each sample.  That offset is a saved value 
(per source) that is fixed when the 'DC Comp' feature is off.  When the 'DC Comp' feature is 
turned on Sigmira monitors the input samples and adapts the saved offset value to the current 
sample stream.

The different signal sources have different characteristics in their DC offset.

The SDR-IQ is relatively well behaved. Once adapted and canceled it basically doesn't change 
unless you change frequency by more that say 100 kHz or change the RF gain. Normal usage 
would be to leave the DC Comp feature off so that is not disturbed by actual signals.  If the DC 
offset becomes annoying tune to a quiet area of spectrum in the neighborhood of the signals of 
interest.  Turn the DC Comp on.  The adaptation takes 5 or 10 seconds.  The results are 
observable in the spectrum/waterfall particularly at the narrow width settings.  When the central 
ridge is minimized turn DC Comp off.

The RTL-SDR I have (with an R820T tuner) seems to have a small DC offset. It can often be 
ignored. It can also be handled as described above for the SDR-IQ.

The SDRplay RSP1 does some compensation for the DC on its own. You can see it adapt after RF
gain changes or large frequency changes. But it is not complete. The Sigmira DC Comp control 
can still be used for better compensation. It is reasonable leave the DC Comp feature clicked on 
the whole time while using the SDRplay. Beyond the DC offset the SDRplay also seems to have 
uncancellable low frequency noise of about 80 Hz width.

3.7 Spectrum Controls

   
Figure 16 - Spectrum Controls

3.7.1 Spectrum Width

The Width buttons control the width of spectrum displayed in the spectrum and waterfall displays.
The maximum supported width for the SDR-IQ/14 is 200 kHz. The maximum supported width 
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for the RTL-SDR and SDRplay RSP1 is 2 MHz.  When the selected source is the sound card or a 
wave file the maximum width available is 25 kHz.  

3.7.2 Spectrum Base

The spectrum base can also be adjusted by rolling the mouse wheel while the cursor is in the 
spectrum display.

3.7.3 Spectrum Scale

There are three buttons, "35 dB", "60 dB", and “100 dB” that control the scale of the spectrum 
and waterfall displays.  Scale here refers to how bright a signal appears in the waterfall display or 
how high above the noise floor it is drawn in the spectrum display.  Adjusting the display scale is 
necessary because absolute signal levels vary considerably.

At the smaller scale value smaller signals will be more prominently displayed.  Note that the 
signal level scale in the spectrum display tracks the scale adjustments so that the indicated levels 
remain calibrated.

3.7.4 Spectrum Pause

The Pause button causes the spectrum, waterfall, phase plane, and eye diagram displays to pause.  
Demodulation, audio output, and all other functions continue.  

3.8 Frequency

The Frequency indicator displays and controls the signal tuning frequency. The radix point is at 
the MHz position. The least significant digit is at single Hz. There are digits to display up to 
9,999.999999 MHz but each receiver/signal source has its own maximum frequency limit.

Figure 17 - Frequency Control

The displayed frequency is the frequency pointed to by the red triangle in the waterfall frequency 
scale.  Positioning the PC mouse cursor over a digit and spinning the mouse wheel causes the 
frequency to roll up or down in that digit position.  Clicking on a digit in the frequency display 
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causes the tuning frequency to be rounded in that digit place.   (i.e. clicking on the 5 in a display 
of  10.500000 causes the frequency to change to 11.000000.)   Clicking on the triangle above a 
digit causes the frequency to increment in that digit.  Similarly, clicking on the triangle below a 
digit causes a decrement.

Clicking on a digit in the frequency display causes the tuning frequency to be rounded in that digit
place. For example, clicking on the '3' in a displayed frequency of “121.378” will round the 
frequency to “121.000”.

As described in the section on the waterfall display, right-clicking in the waterfall display (or the 
frequency scale, or the spectrum display) causes the tuning frequency to change to the frequency 
of the point clicked.  If the Lock Center box is not checked then the center of the displayed 
spectrum range changes to that frequency.  Consequently the red triangle will always be at the 
center of the display.

If the Lock Center box is checked then the center frequency of the displayed spectrum is fixed.  
When the tuning frequency is changed the red triangle will move to the corresponding location in 
the frequency scale.  This is useful when the center frequency has been set to be within a group of
signals of interest.  The tuning can be changed from signal to signal and the red triangle will 
follow while the signals maintain their positions in the spectrum display.

3.9 Demodulation Width

The demodulation width control adjusts the bandwidth used in demodulating the signal.  Signals 
vary in width.  It is advantageous to adjust the demodulation width to be wide enough to include 
the signal but no wider so that no extra noise is included.

Figure 18 - Demod Width

The demodulation width control is effective in the AM, USB, LSB, and NFM modes.  AM and 
SSB signals have considerable variability in width.  In the other modes (particularly CW, PSK31, 
FSK, RTTY, S4285, HFDL, and FLEX) the signals have defined widths and the demodulators are
tailored to those widths.
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The selectable widths refer to the demodulated output.  AM signals are double sideband.  So the 
transmitted width of an AM radio signal is twice that of the modulation.  The transmitted radio 
signal for AM with 5 kHz modulation will be 10 kHz wide as seen in the spectrum/waterfall 
display.  For such a signal the 5 kHz demodulation width would be appropriate.  For SSB signals 
the transmitted width is the same as the modulation width.

AM broadcast signals have modulation bandwidth of 5 or 10 kHz typically.  Ham SSB signals are
typically 2.5 to 3 kHz wide.

3.10 Strength Indicator

The Strength indicator is a thermometer-like display that indicates the strength of the 
demodulated signal.

Figure 19 - S-Meter

If an  SDR receiver is selected as the source then the strength scale is similar to a traditional S-
Meter.  The tick marks are "S-Units" up to "S9" and then dB above S9 above that.  (Only S5 and 
S9 are marked with digits to save clutter.)  S9 is -73 dBm or 50 Vrms at the antenna input.

If the sound card or .wav file is selected as the source then the strength scale is relative.  (It is not 
possible to accurately calibrate sound wave samples to radio signal strength.  Recorded .wav files 
can have a wide range of recording levels.  And an external receiver connected to the sound input 
typically has an AGC which results in a relatively constant audio level.)  The strength scale is 
logarithmic.  Full scale corresponds to the full strength representable by sound sample values.

Besides general curiosity, the Strength indicator is useful in adjusting the squelch (see section 
3.11, Squelch Control) and setting up the optimum input level (see section 6, Conventional 
Receiver Connection).

3.11 Squelch Control
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The squelch controls when the demodulation of the incoming signal is active.  It sets a minimum 
strength level that the signal must reach in order to be demodulated.  This is useful in preventing 
the background noise between transmissions from being interpreted as signal.

The squelch is a slider control that is controlled by clicking on it and sliding it up or down.

Figure 20

The squelch control is located next to the signal strength indicator and their levels correspond.  If 
the indicated signal strength is higher than the squelch the demodulation will be active.  If the 
squelch control is set to the bottom of  its range the demodulation will always be active.

In CW mode the squelch control has a somewhat different function.  In CW mode (Morse mode) 
the squelch control can optionally be used to set the signal level that is considered as "key down". 
When the signal level is above the squelch level it is considered a "key down" period, i.e. part of a
'dit' or a 'dah'.  When the signal level is below the squelch level it is consider to be a "key up" 
interval, i.e. between a 'dit' or 'dah'.  But it is not necessary that the best setting for this control be 
selected manually.  If the squelch level is set at 0, at the bottom, the program automatically 
adjusts to what it calculates is the best level.

3.12 Mute

The Mute button controls whether the demodulated audio is played out to the PC sound output. 

3.13 File Menu

The File menu is in the menu bar at the top of Sigmira's window.  The File menu has two entries, 
Open and Quit.
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Figure 21 - File Menu

3.13.1 Open

Selecting Open brings up a dialog window that can be used to open an audio file.  The file would 
typically be previously recorded undemodulated signal as from the short-wave receiver output.  
Once opened Sigmira will play and demodulate the signal just as if it were live input.

The file can be a .wav format file with any normal sample rate from 8000 to 48000 Samples/sec.

Several example .wav  files are included with Sigmira.  They are useful in demonstrating 
Sigmira's operation. See section 8, 'Wave File Input'.

3.14 Source Menu

Sigmira can operate with input from several different signal sources.  The source is selected with 
the 'Source' menu at the top left of the main window.

  
Figure 22 - Source Menu

3.14.1 SDR-IQ, SDR-14, RTL-SDR

If the device is connected operation will start immediately when selection is made.  
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3.14.2 SDR-IP

The SDR-IP is not supported at this time.

3.14.3 WaveIn (Sound Card)

If “WaveIn” is selected the signal input is taken from the sound card or other Windows “Wavein” 
device. That may include “Virtual Audio Cables” if any are installed.

Often the sound card is used as the source when Sigmira is used with an external conventional 
receiver.  The receiver's audio output is connected to the sound card input.  See section 6 of this 
document.

Virtual Audio Cables, VB Cables, or similar utilities allow you to pipe the output from another 
SDR program into Sigmira. The other program must be set to output the audio to the virtual audio
cable. Sigmira can then be used to further demodulate signals that the other program may not 
demodulate. Examples would include modes such as STANAG 4285, FSK, HFDL, etc.

As soon as you select WaveIn as the source the WaveIn Select window pops up. That allows you 
to select the specific input among the available inputs. It also allows you to select the sample rate 
and whether the input is I/Q. The WaveIn Selection window is also accessible via the 
Other=>WaveIn Select menu.

  
WaveIn Selection Window

Copyright 2008, 2011, 2016, 2020, 2021 Steven A. Harlow 47



Sigmira 1r13

The currently selected input is shown at the top. You can select a different input to use by clicking
on it in the table.

I/Q
Many SDR programs offer output in I/Q (in-phase and quadrature) format. This is advantageous 
in that it provides twice the bandwidth and angle modulated signals can be processed without a 
frequency shift and offset. If the source program provides I/Q format click the I/Q checkbox. 
Sigmira will show 0 Hz in the center of the spectrum display and “negative” relative frequencies 
will be shown to the left. In this configuration you will not have to tune the source program such 
that the signal appears entirely in the positive half of Sigmira's spectrum display. Even if the 
signal extends into the negative frequency range you can right click to set Sigmira's tuned 
frequency to the reference center of the signal. Demodulation can then proceed.

Flip I/Q
Normally the in-phase signal is expected from the left channel and the quadrature signal is 
expected from the right channel. Some SDR programs reverse that. When the source and Sigmira 
don't match the spectrum display will be reversed with the lower frequency signals toward the 
right. This checkbox allows you to switch and match to what the other SDR source provides. 

Sample Rate
Except for broadcast FM and television signals all other signals can fit within the bandwidth 
provided by the 44.1 ksps sample rate. The 192 ksps sample rate allows for a wider range 
spectrum display. The VAC utilities appear to automatically adapt to the sample rate requested. 
The actual bandwidth of the data provided is limited to the internal rate of the utility. The free 
version of one VAC utility is limited to 48 ksps. So when you select 192 ksps it provides 192 ksps
but the information in those samples is limited to the equivalent of 48 ksps.

Note that when a WaveIn source is selected Sigmira's frequency controls do not control the tuning
of the external source.

3.14.4 Wave File

Playback begins when a .wav file is opened with the File->Open selection.  (Opening a wave file 
with File->Open also automatically sets the Source selection to Wave File.) Also see section 8.

3.14.5 SDRplay RSP Devices

Sigmira offers limited direct support for the SDRplay RSP devices. Sigmira will control the first 
tuner and will only use the first antenna input. Sigmira will also take the output from SDRuno via 
virtual audio cables. So you can use SDRuno to have full control over any RSP device and use 
Sigmira for further signal demodulation. See section 3.14.3 in this document.

For direct support Sigmira works with the versions 3.06, 3.07, and hopefully future versions of 
the SDRplay API. Install SDRuno with the API in order to have the API installed and available.
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3.15 View Menu

Sigmira has several displayable sub-windows.  They include the Signal Database, Phase Plane, 
S4285 Control, and Rx Text displays.  They are described in sections 3.3 and 3.4.  The View 
menu can be used to cause these sub-windows to be viewable.

  
Figure 23 - View Menu

3.16 Calibrate Menu

Under the top level "Other" menu there is a menu item that allows for calibration of the SDR-IQ 
crystal frequency.

Figure 24 - Calibrate Menu

3.16.1 Calibrate Frequency

The SDR receiver devices operate with a quartz crystal oscillator frequency standard.  Crystal 
oscillators are highly accurate but have some small frequency offset.  That offset is evident with 
current  communications technology.  Fortunately it is easy to compensate for the offset.
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Figure 25 -  Frequency Calibration

The SDR-IQ Xtal Calibration window allows one to adjust Sigmira to cancel out the frequency 
offset (for any of the SDR receiver devices).  When the window comes up both the 'Indicated 
Tuning' and 'Actual Tuning' are set to the current indicated tuning.  If either one is known to be 
incorrect the correct value can be entered.  When the 'OK' button is clicked Sigmira will adjust so 
that thereafter the indicated frequency will match the actual.

As an example of how this can be done: One would tune to a known frequency standard such as 
WWV.  The higher the frequency the more accurate the calibration. Bring up the phase plane 
display.  (See section 3.4.)  The signal should appear as a dot or line segment radiating from the 
center of the display.  If Sigmira is tuned exactly to the carrier frequency the dot/line will be 
stationary and not revolve around the center.  If the signal is higher in frequency the dot/line will 
revolve around the center counter-clockwise.  Adjust the tuning frequency so that the dot/line 
motion is the minimum possible.  At this point the actual frequency will be most correct.  Bring 
up the calibration window.  Correct the displayed 'Actual Tuning' to be the known correct 
frequency of the reference signal and click 'OK'.  (Note that the best practically achievable 
accuracy is about 0.5 Hz and that the crystal reference can easily drift several Hz in an hour.)

The 'Factory Default' button allows the calibration to be reset to the original nominal value.

4 Signal Database

The Signal Database allows one to log, categorize, recall, and instantly tune to signals.  The 
number of entries is unlimited.  A database already containing over a thousand entries is included 
in the Sigmira package.

The Signal Database is brought up by clicking the menu View=>Signal Database in the Sigmira 
main window.  The Signal Database will appear as shown in Figure 26, below.
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Figure 26 - Signal Database

Each signal entry in the database is one row. Right-clicking on a row tunes Sigmira to the 
frequency shown in Frequency field for the selected entry.  The right-click also sets the 
demodulation mode according to the Mode field.

4.1 Sorting

Each entry has six fields: Frequency, Mode, Description, Cat1, Cat2, and Parameters.  The six 
fields make up the six columns of the view.  Left-clicking on the heading of a column causes the 
database view to be sorted based on that field.  Clicking a column heading the first time causes an 
ascending sort.  Clicking a second time causes a descending sort.  If a signal entry is already 
selected when a sort is performed then that signal entry will be scrolled to the center of the view.

4.2 Editing

All of the fields of an entry are editable.  Left-click on a field twice in order to edit it.  Note that 
edits made are not saved to disk until Save or Save As is clicked in the Signal Database window 
File menu.
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4.3 Fields

The Frequency field is in MHz.  Whenever a new database entry is created Sigmira automatically 
enters the currently tuned frequency.

The Mode field corresponds with the demodulation modes in the upper left of the Sigmira main 
window.  The Mode field is not case sensitive.  "am", "AM", "aM", and "Am" are all equivalent.  
If the content of the Mode field doesn't correspond with one of Sigmira's recognized modes 
Sigmira defaults to USB.  Whenever a new database entry is created Sigmira automatically enters 
the currently selected mode.

The Description field is available for any descriptive information the user would like to associate 
with the signal.  Whenever a new database entry is created Sigmira automatically enters the string
"new" plus the current date and time.  This may of course be edited.

The Cat1 and Cat2 fields offers a means to place signals in user defined sortable categories.  
Clicking on the head of the Cat1 or Cat2 column will sort the database based on the contents of 
that field.  So if all of the "numbers" station signal entries have the string "numbers" in the Cat1 
field then sorting on the Cat1 column will display the numbers stations grouped together.

The contents of the Cat1 field are also interpreted to give a background tint to each entry.  Ten 
predefined values for the Cat1 field are recognized.  The values and the associated colors are 
given in the table below.  The categories correspond roughly with the categories in the US 
Frequency Allocation Chart, http://www.ntia.doc.gov/osmhome/Chp04Chart.pdf. 

Cat1 field value Tint
av light blue
broadcast yellow
cb light yellow
curious pink
fixed brown
ham green
maritime blue
misc gray
numbers red
ref light gray

The Parameters field provides a means to associate additional demodulation parameters with a 
signal.  The Parameters field will be fully implemented in a future version of Sigmira.   The 
parameters can include things such as bit rate and interleave for STANAG 4285 signals or shift 
and baud rate for FSK signals, etc.

4.4 Buttons
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Clicking the Freq Lookup button in the upper right portion of the Signal Database window causes 
the entry in the database closest in frequency to the current main tuning to be scrolled to the 
center of the database window and highlighted.

Clicking the Delete button in the upper center portion of the Signal Database window causes the 
current selected entry to be deleted.

Clicking the New button in the upper left portion of the Signal Database window causes a new 
entry to be created.  The Frequency field of the new entry is automatically filled in with the 
current tuning frequency as shown in the Sigmira's main window.  The Mode field is 
automatically filled in with the current mode.  The Description field is filled in with the string 
"new" plus the current date and time.

4.5 Signal Database File Menu

In the menu bar at the top of the Signal Database window is a File menu.  The File menu has four 
entries, Open, Read, Save and Save As.

Selecting File=>Open brings up a dialog window that can be used to open a signal database file.  
At startup Sigmira automatically opens the signal database file "sigmira.sdb".  Using the Open 
dialog a different file can be opened.  The contents of the newly specified file become the 
operating signal database.  The newly specified file name also becomes the default for the Save 
function.

Selecting File=>Read brings up a dialog window that can be used to read in an additional signal 
database content from a file.  The contents of the file are added to the current operating signal 
database.  The file name specified in the Read operation does not change the default file name for 
Open and Save operations. 

The signal database can be saved to disk by following the File=>Save or File=>Save As menu 
dialogs in the Signal Database window.  The Save operation saves the signal database to the 
default signal database file name.  The default file name at start-up is "sigmira.sdb".  With the 
Save As operation the database is saved to a newly specified file.  The newly specified file name 
becomes the default file name.  Subsequent 'Save' selections will write to the remembered 
destination file name.  Any save to a file overwrites the previous contents if any.

On exit Sigmira backs up the current database contents to the file "sigmira_bu.sdb" regardless of 
other operations.

5 SDR-IQ Operation

Connect the SDR-IQ to the computer with the USB (Universal Serial Bus in this case) cable.  
Connect an antenna to the SDR-IQ.  Start Sigmira and select the SDR-IQ as the signal source 
via the 'Source' menu at the top left of the window.
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6 Conventional Receiver Connection

Sigmira can operate with a conventional short-wave receiver. The receiver must have and must be
operated in the Single Sideband (SSB) mode.  Upper Sideband (USB) mode is preferable.

Connect the audio output of a short-wave receiver to the audio "Line In" audio input of the PC.  

If you are fortunate your receiver will have an output that is before the volume control.  In that 
case the PC receives a good constant level signal regardless of the receiver's volume control 
setting.  On some receivers such an output is labeled AFSK Out.  Otherwise you can tap the 
speaker output, set the volume for a moderate level, and avoid making changes to the level.

Adjust the gain and volume controls so that the signal isn't so strong that it becomes clipped or 
distorted.  The controls on the receiver and also the PC's Recording Control window can be use to
make adjustments.  The PC sound controls can be accessed by clicking start=>run... and typing 
"sndvol32" or they can be accessed through the control panel by clicking start=>Control 
Panel=>Sound and Audio Devices=>Audio=>Volume.  The resulting window will likely look 
like:

Figure 27

(It is a good idea to mute the "Line In" in the Master Volume window.)

Then the "Line In" input needs to be selected in the Recording Control.

To get to the Recording Control window select Options=>Properties=>Recording.  You should 
get a window like:
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Figure 28

Click the Select box under Line In and then adjust the Volume slider.

The optimum volume level setting is obtained when even the strongest input does not "peg" 
Sigmira's Strength indicator.  Start Sigmira, select "Sound Card" source, and select the AM mode.
Tune in a strong signal (of any type) on the receiver.  Observe the Sigmira Strength indicator and 
adjust the volume so that the strength indicator never goes to full scale.

Figure 29

7 Operation with Networked Receivers

7.1 General

There are various SDR receivers that are accessible via the internet. There are various protocols or
interfaces associated with these receivers. Sigmira currently supports the RFSpace/MoeTronix 
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RemoteSDR/SDRanywhere protocol. Currently there are about ten receivers that are accessible. 
They are located mostly in Europe and North America. A live list with their status is accessible at 
http://sdranywhere.com/cloud/sdrweb.py. More on RemoteSdrClient and SDRanywhere can be 
found here http://moetronix.com/remotesdrclient.html and here 
http://www.sdranywhere.com/SDRanywhere/SDRanywhere.html. 

To use a networked receiver first bring up the Network Database window. Go to the main window
and select the menu item View->Network Database.  The "Network Connections" window is then
displayed as illustrated below.

The background tint of each entry has the following meaning:
 gray The entry is either the one currently selected or is from the local sigmira.ndb

file.
 light yellow The entry is from the online database.
 darker yellow The entry is from the online database but the receiver/server is either private

or currently occupied.

To connect to a networked receiver:
1. left-click on the entry
2. left-click on the "Connect" button.
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Sigmira then goes through the connection process. The status and progress are displayed in the 
"Connection Status" text box. On a successful connection the status box will show something 
like:
   Connected to: CI000160

Sigmira then receives, displays, and demodulates signals as it does from other source but with a 
few differences.

7.2 Networked Receive Characteristics

There is a detectable delay through the network connection and due to the compression used to 
reduce network bandwidth usage.  There is about a second delay from changing the tuning 
frequency until the result is heard in the audio.

For Sigmira's data modes (PSK31, CW, S4285, FSK, etc.) Sigmira puts the networked receiver in 
USB mode. The typical steps to demodulate a data signal such as S4285 would be: 

 Set the Spectrum Width to 10 kHz.
 Tune such that the data signal fits in the upper sideband passband of the receiver.  That is, 

right-click at the left edge of the signal so that the signal falls in the 300 to 3000 Hz range 
of the upper sideband. The center of an S4285 signal would then be at about 1500 to 1800 
Hz in the displayed spectrum.

 Lock the main tuning center frequency with the "Lock Center" check box in the main 
window.

 Then in the spectrum display right-click at the center of the S4285 signal.  (A S4285 
signal has a divot at the center of its spectrum that is visible if the fading is not too 
severe.) The center frequency of a S4285 signal is typically a number like xxx.000, 
xxx.200, xxx.400, xxx.500, or xxx.800 MHz.

 Select S4285 mode. The Sync indicator should turn green.  It may be necessary to bump 
the frequency up or down for best results. Don't forget to uncheck the "Lock Center" box 
when done decoding a particular data signal and tuning to a different signal.

(Yes, all that is a bit of an inconvenience. I could make it automatic. Maybe in a future version.)

7.3 Editing the Network Receiver Database

Network receiver entries can be added and edited.  At this time there isn't really a need to 
manually add entries The contents are read from the online database. You can click on 
Edit=>Refresh in the Network Connections window to update the displayed information. That 
will also update the displayed available/occupied status of the receivers.

One might add an entry via the Network Connections window Edit->New Connection menu item.
Added entries will have the gray background.
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Entries can be edited by selecting the entry (left-click) and then left clicking on the field to edit.

Entries with the gray background can be saved to the local sigmira.ndb file.  Select File->Save.  
Entries from the online database (yellow background) are not saved to the local file.

7.4 Network Receive Disconnect

The Disconnect button can be used to disconnect from a receiver. When Sigmira is currently 
connected to networked receiver and it is desired to connect to a different receiver or to switch to 
a different input source (e.g. a local SDR-IQ) it is not necessary to click the Disconnect button 
first.  Sigmira does the disconnect automatically.

8 Wave file Input

Sigmira can operate on prerecorded .wav files without an external receiver connected.  Start the 
program and from the top menus select:  File => Open.  To find the example files first click on the
"Sigtools" button:

Figure 30

The "examples" directory will then appear.  Double-click on it:
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Figure 31

Then select the RTTY example file by double-clicking on it:

Figure 32
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The example file will then start playing.  Click on the Spectrum Width 5 kHz button.  Right-click 
on the 1070 mark on the waterfall frequency scale.  The display will look something like:

Figure 33

Click on the RTTY mode 'radio button' as described in section 3.5.

The demodulated message will then start to appear:
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Figure - 35

9 Credits

Sigmira is Copyright 2021 by Steven A. Harlow.  All rights reserved. 
http://www.saharlow.com/technology/sigmira     
Sigmira is a trademark of Steven A. Harlow. 

SDR-IQ and SDR-14 are trademarks of RFSpace, Inc.     http://www.rfspace.com/Home.html
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