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1 Introduction

XDFilt is a Windows application program for filtering and removing noise from audio signals.
The audio source can be saved .wav files, external live input as from a radio receiver, or external
prerecorded material as from audio tapes, phonograph records, etc.

Its features include:
• Adaptive removal of uncorrelated (random) noise.
• Adaptive removal of correlated (whistle/heterodyne) noise.
• "XD" adaptive removal of random noise.
• Point-and-click graphical user-defined filter.
• "Waterfall" spectrographic display.
• 'Live' input from radio receiver, cassette player, turntable, etc. to standard PC sound

interface.
• 'Canned' input from saved .wav files.
• 16 bit sampling.  8 k-sample/s sampling rate.
• Signal strength meter.

The distribution package includes examples of noisy signals in .wav files.

The intended application of XDFilt is for filtering of voice, music, and CW signals, i.e. signals
that a person listens to.  While certainly useful for CW it is not particularly appropriate for other
narrow band digital signals such as RTTY, PSK, SITOR, etc.

2 Installation

The application is distributed in the executable self-installer 'sigtools_1r0_installer.exe'.  To
install XDFilt simply run the installer.  (sigtools_1r0_installer.exe is a combined installer for
XDFilt and Sigmira.)

(On some machines a pop-up window will appear asking if a .bat script should be allowed to run.
If that happens click 'Allow' and see section 7 - Installation Details.)

Instructions on connecting the radio receiver are given in section 6, but connecting a receiver is
not necessary in order to run the demo.

3 Cut to the Demo

3.1 Main Demo
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For a quick demonstration of what XDFilt can do, play one of the example files.  Start the
program and from the top menus select:  File => Open.  To find the example files first click on the
"sigtools_1r0" button:

Figure 1

The "examples" directory will then appear.  Double-click on it:

Figure 2
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Then select the "am_7r375_070611_0645.wav" example file by double-clicking on it:

Figure 3

The example file will then start playing.  The display will look something like:

Figure 4

To hear the signal coming out of the PC's speakers click on the "Speaker" button:
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Figure 5

The filtered signal should now be audible from the PC's speakers.  At start-up XDFilt defaults to
generally appropriate filter settings.

To contrast the effect of XDFilt versus the raw signal toggle the master filtering control.

Figure 6

The effectiveness of XDFilt should be evident.

3.2 Graphical Filter Demo

The Graphical filter feature of XDFilt can be used to remove the "heterodyne" interfering tones
also present in the example file used above ("am_7r375_070611_0645.wav").  The strongest such
interfering tone appears as a vertical line in the waterfall display below about the 1400 Hz tick
mark in the frequency scale.

Enable "Filtering" and the "Graphical" filter.
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Figure 8

If the example file has finished playing open it again to start it playing. Move the cursor to the
lower edge of the graphical filter display (see below) somewhat to the left of the "heterodyne",
right click, drag the cursor somewhat to the right of the "heterodyne", and release the mouse
button.

Figure 9

As shown below, the graphical filter response curve will be updated showing the notch and the
waterfall display will show that the corresponding frequency components are removed from the
signal.  Listening to the output will also demonstrate that the interfering tones have been removed.



XDFilt 1r0 July 23, 2007

Copyright 2007, Steven A. Harlow 8

Figure 10

4 Operating Controls and Displays

4.1 Overview

The XDFilt window is divided into three main sections.  The upper section is dominated by the
filter setting controls.  The middle section displays and controls the graphical filter.  The lower
section is a waterfall spectrographic display in which the signal and the affects of the filtering on
the signal can be viewed.

The order of items in the upper section, left to right, generally corresponds the path of the signal
as it is processed.

4.2 "Filtering" Block

The Filtering block is in the upper third of the display and contains the main filtering controls.
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Figure 11

The Filtering checkbox in the upper left corner is the master filtering control.  All filtering is
bypassed  unless the Filtering checkbox is checked.

The Filtering block contains three sub-filtering blocks: "Corr", "Graphical", and "Full Band".  The
order of these blocks, left to right, is the order in which the signal is processed by these filters.

4.2.1 "Corr" Filter

The "Corr" filter removes highly correlated components.  Highly correlated components include
whistles, squeals, and heterodynes.

The corr filter is bypassed when its checkbox is not checked or when the main Filtering checkbox
is not checked.  There are no other adjustments to the corr filter.

If there are multiple heterodynes in a signal the corr filter will be most effective against the
strongest of them.  Also, if there is phase jitter in the heterodyne the effectiveness of the corr filter
is reduced.  Often better results are obtained by using the graphical filter and creating a notch for
any continuous interfering components.

4.2.2 "Graphical" Filter

The "Graphical" filter is a frequency selective filter.  The frequency response is completely
controlled by the user graphically.  The graphical filter is bypassed when its checkbox is not
checked or when the main Filtering checkbox is not checked.
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The frequency response curve of the graphical filter is displayed in the middle section of the
XDFilt window.  The horizontal scale is frequency and is the same as for the waterfall display.
The vertical scale is gain in dB.

The user sets the frequency response by drawing in the display area with the mouse.
Modifications to the curve are made in line segments.  To modify a segment of the curve place the
cursor at the beginning of the desired segment, press and hold the right mouse button, drag to the
end of the desired segment, and release the button.  The segment is shown in green as it is being
drawn.  (Green lines are also shown at the ends of the new segment showing where it will connect
to the existing curve.)

Figure 12

Complex shapes can be made from a number of line segments.  That is illustrated below along
with the affect on a white noise signal.

Figure 13

The background of the graphical filter display is white when the filter is active and gray when not
active.  The curve can be modified whether or not the filter is active.
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Ostensibly the adjustable gain range is continuous 0 to -25 dB.  However the gain jumps to -∞ dB
at the very bottom of the range.  (A setting just above the bottom is -25 dB.  A setting at the
bottom is -∞ dB.)

4.2.3 "Full Band" Filter

The "Full Band" filter attempts to remove static or thermal noise across the full bandwidth of the
signal. The full band filter is bypassed when its checkbox is not checked or when the main
Filtering checkbox is not checked.

Two types of filter can be selected under Full Band.  By clicking on the associated radiobutton
either the "XD" or the "Uncorr" filter can be selected.

Noise filtering is a compromise between removing noise and distorting the signal.  The best
selection and settings of the filter is subjective and varies with the input signal conditions.
Experiment.

4.2.3.1 "XD" Filter

The "XD" filter can be quite effective against broadband static or thermal noise.  It also has
performance advantages over the Uncorr noise filter.

The XD filter has two modes of operation, Auto and Manual, selectable via the associated
radiobuttons.  Each mode has a slider control.  In the manual mode the user selects a fixed level of
filtering directly with the manual mode slider.  In the auto mode the filter automatically adjusts
the level of filtering and the user sets the aggressiveness of the automatic adjustment with the auto
mode slider.  The manual mode is more appropriate when the noise level is relatively constant.

4.2.3.2 "Uncorr" Filter

The "Uncorr" filter adapts to and passes the input components that are more correlated (i.e. the
desired signal generally) and rejects the uncorrelated components (the noise generally).  It is
effective but it also tends to exaggerate multipath fading.

4.3 Waterfall Display

The waterfall display is a spectrographic display of the signal post filtering.

The waterfall display is the bottom third of the window.  It is a graphical display of frequency
content versus time.  Higher frequency components are displayed to the right.  The strengths of
the frequency components are represented by brightness/color.  The display shifts down with time
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so that the most recent signal content is displayed upper most.  The display has a frequency scale
along the top and a time scale along the left edge.

The effects on the signal of the various filtering settings, Corr, Graphical, Full Band, etc. are
evident as the filtered signal is displayed in the waterfall.

4.4 Strength Indicator

The Strength indicator is a thermometer-like display that indicates the strength of the input signal.
See Figure 16.

Besides general curiosity, the Strength indicator is useful in setting up the optimum input level
(see section 5, External Source Connection).

4.5 Speaker

The speaker control is pretty straight forward.  The speaker control is located toward the upper
right corner of the XDFilt window.  The checkbox is a speaker on/off control.  It defaults to off at
program startup.  The slider is the volume control.

4.6 Record

The Record feature is not implemented in XDFilt version 1r0.

4.7 File Menu

The File menu is one of the menus in the menu bar at the top of XDFilt's window.  The File menu
has two entries, Open and Quit.

4.7.1 Open

Selecting Open brings up a dialog window that can be used to open an audio file.  The file would
typically be previously recorded signal.  Once opened XDFilt will play and filter the signal just as
if it were live input.  While the file is playing live input is disabled.

The file should be a .wav format file with an 8 k-Sample/sec sample rate.

Several example .wav  files are included with XDFilt.  They are useful in demonstrating XDFilt's
operation. See section 3, 'Cut to the Demo', in this document.
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5 External Source Connection

The external source can be any audio signal source: radio receiver, phonograph player, tape
player, CD player, etc.

The external source should be connected to the audio "Line In" input of the PC.

The main objective is to adjust the gain and volume controls so that the input signal is strong but
isn't so strong that it becomes clipped or distorted.  The controls on the audio source and also the
PC's "Recording Control" window can be adjusted.

Generally it is best to set the volume of the source to the maximum that doesn't overdrive XDFilt,
then leave the source volume fixed, and use XDFilt's speaker volume control to set the desired
listening level.

(When the source is a radio receiver it may be that the receiver has an output that is before its
volume control.  If such is the case that output can supply the PC with a good constant level
signal regardless of the receiver's volume control setting.  On some receivers such an output is
labeled AFSK Out.  Otherwise you can tap the speaker output, set the volume for a moderate
level, and avoid making changes to the level.)

The PC sound controls can be accessed by clicking start=>run... and typing "sndvol32" or they
can be accessed through the control panel by clicking start=>Control Panel=>Sound and Audio
Devices=>Audio=>Volume.  The resulting window will likely look like:

Figure 14

(It is a good idea to mute the "Line In" in the Master Volume window.)

Then the "Line In" input needs to be selected in the Recording Control.
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To get to the Recording Control window select Options=>Properties=>Recording.  You should
get a window like:

Figure 15

Click the Select box under Line In and then adjust the Volume slider.

The optimum volume level setting is obtained when even the strongest input does not "peg"
XDFIlt's Strength indicator.  Start XDFilt and apply a normal, strong signal.  Observe the XDFilt
Strength indicator and adjust the volume so that the strength indicator never goes to full scale.
With a good input level setting the Strength indicator will be at the one half to two thirds level on
average.

Figure 16
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6 Installation Details

On some machines XDFilt may not install correctly on the first install.  In that case there are two
visible symptoms.  One is that at installation time a pop-up will appear asking if a .bat script
should be allowed to run.  The other is that when XDFilt is started after installation its lettering
appears as squares rather than letters.

The cause is that the PC's particular security settings blocked a .bat script that the installer uses.  It
should be allowed to run.  The script is necessary and it is not harmful.  (The script remains under
the installation directory and can be examined.)

Unfortunately allowing the script to run doesn't always work on the first install.  It does work on
the second install.  The reliable solution if the problem occurs is to allow the script on the first
install, uninstall, and then install again.

7 Credits

XDFilt and Sigmira are Copyright 2007 by Steve Harlow.  All rights reserved.

XDFilt and Sigmira use GTK, Pango, and Cairo, which are licensed under the GNU Lesser
General Public License (LGPL).


